Zephyr MCP is down

Incident Report for Zephyr Cloud

Resolved

Zephyr MCP is operational again.
Posted Jun 08, 2026 - 11:15 UTC

Investigating

Zephyr MCP has been shut down to rollback a previous deployed version.
Posted Jun 08, 2026 - 09:56 UTC
This incident affected: Zephyr Remote MCP.