Zephyr is not accessible

Incident Report for Zephyr Cloud

Resolved

This incident has been resolved.
Posted Nov 27, 2025 - 11:00 UTC

Update

There has been an issue when loading the frontend application, it's now back to normal.
Posted Nov 27, 2025 - 10:59 UTC

Update

We are continuing to investigate this issue.
Posted Nov 27, 2025 - 10:38 UTC

Investigating

We are investigating the issue
Posted Nov 27, 2025 - 10:38 UTC
This incident affected: Zephyr Cloud (US) and Zephyr Cloud (EU).